Back to overview
Downtime

Plex and Overseerr are down

Aug 31, 2026 at 12:37pm UTC
Affected services
Plex
Seerr

Updated
Aug 31, 2026 at 12:38pm UTC

Fibre Outage (Estimated Resolution - 01/09/26 17:00 NZDT)

Created
Aug 31, 2026 at 12:37pm UTC

Fibre Outage (Estimated Resolution - 01/09/26 17:00 NZDT)